1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Thijs Vermeir <thijsvermeir@gmail.com>
3 # Contributor: Denis Zawada <deno@rootnode.net>
8 pkgdesc="Library to ease handling and implementation of UPnP A/V profiles"
9 url="https://wiki.gnome.org/Projects/GUPnP"
12 depends=(glib2 libxml2)
13 makedepends=(gobject-introspection gtk-doc vala meson git)
14 _commit=86f148ebb920a8113190fd3e6cae636c9fdd3ca7 # tags/gupnp-av-0.14.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/gupnp-av.git#commit=$_commit")
20 git describe --tags | sed 's/^gupnp-av-//;s/[^-]*-g/r&/;s/-/+/g'
28 arch-meson gupnp-av build -D gtk_doc=true
29 meson compile -C build
33 meson test -C build --print-errorlogs
37 depends+=(libg{lib,object}-2.0.so)
38 provides+=(libgupnp-av-1.0.so)
40 meson install -C build --destdir "$pkgdir"
43 # vim:set sw=2 sts=-1 et: