archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gupnp-av / trunk / PKGBUILD
blobf00d82962beb026ad13c53c94b99551eff938f06
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Thijs Vermeir <thijsvermeir@gmail.com>
3 # Contributor: Denis Zawada <deno@rootnode.net>
5 pkgname=gupnp-av
6 pkgver=0.14.1
7 pkgrel=2
8 pkgdesc="Library to ease handling and implementation of UPnP A/V profiles"
9 url="https://wiki.gnome.org/Projects/GUPnP"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(glib2 libxml2)
13 makedepends=(gobject-introspection gtk-doc vala meson git)
14 _commit=86f148ebb920a8113190fd3e6cae636c9fdd3ca7  # tags/gupnp-av-0.14.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/gupnp-av.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd gupnp-av
20   git describe --tags | sed 's/^gupnp-av-//;s/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd gupnp-av
27 build() {
28   arch-meson gupnp-av build -D gtk_doc=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   depends+=(libg{lib,object}-2.0.so)
38   provides+=(libgupnp-av-1.0.so)
40   meson install -C build --destdir "$pkgdir"
43 # vim:set sw=2 sts=-1 et: