archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kde-inotify-survey / trunk / PKGBUILD
blob411638fb5112868546b26dcb0f2126d09f968612
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kde-inotify-survey
4 pkgver=23.04.1
5 pkgrel=1
6 pkgdesc='Tooling for monitoring inotify limits and informing the user when they have been or about to be reached'
7 url='https://invent.kde.org/system/kde-inotify-survey'
8 arch=(x86_64)
9 license=(GPL LGPL)
10 groups=(kde-applications kde-system)
11 depends=(kauth knotifications ki18n kdbusaddons)
12 makedepends=(extra-cmake-modules)
13 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('0e0b90a45aa9aeb76dfa80fd2324c9c88e1c0a6b47a8c7ea222773b1d016bdd4'
15             'SKIP')
16 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
17               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
18               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build