archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-5compat / trunk / PKGBUILD
blob8625adb0b1e809e46118ba51a5cb18f74d1b2cad
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-5compat
6 _qtver=6.5.0
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Module that contains unsupported Qt 5 APIs'
13 depends=(qt6-base)
14 makedepends=(cmake ninja qt6-declarative qt6-shadertools)
15 optdepends=('qt6-declarative: for QtGraphicalEffects' 'qt6-shadertools: for QtGraphicalEffects')
16 groups=(qt6)
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('a9e2f53a193fc2e131b01a2f6e7a1fbfe31309c2413fdc213e5a81c558c21261')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -d "$pkgdir"/usr/share/licenses
31   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname