archrelease: copy trunk to extra-x86_64
[arch-packages.git] / vala / trunk / PKGBUILD
blob4a70bf8f83458cc1c6423856da1ff269c51d54b0
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 # Contributor: Timm Preetz <timm@preetz.us>
6 pkgname=vala
7 pkgver=0.56.7
8 pkgrel=1
9 pkgdesc='Compiler for the GObject type system'
10 url='https://wiki.gnome.org/Projects/Vala'
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(
14   gcc
15   glib2
16   graphviz
17   gtk-doc
18   pkg-config
19   ttf-font
21 makedepends=(
22   autoconf-archive
23   git
24   help2man
25   libxslt
26   vala
28 checkdepends=(
29   dbus
30   gobject-introspection
31   libx11
33 provides=(
34   libvala{,doc}-${pkgver%.*}.so
35   valadoc
37 conflicts=(valadoc)
38 replaces=(valadoc)
39 _commit=0b562610d85a2a5d56d489757c2c499d3e652b8c  # tags/0.56.7^0
40 source=("git+https://gitlab.gnome.org/GNOME/vala.git#commit=$_commit")
41 b2sums=('SKIP')
43 pkgver() {
44   cd vala
45   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
48 prepare() {
49   cd vala
50   NOCONFIGURE=1 ./autogen.sh
53 build() {
54   cd vala
55   ./configure --prefix=/usr
56   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
57   make
60 check() {
61   cd vala
62   make check
65 package() {
66   cd vala
67   make DESTDIR="$pkgdir" install
70 # vim:set sw=2 sts=-1 et: