6.3.1.arch2-1
[arch-packages.git] / appstream-glib / trunk / PKGBUILD
blob7da32ffff8be3f1bd527e33188e1b5873d528402
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=appstream-glib
5 pkgver=0.8.2
6 pkgrel=2
7 pkgdesc="Objects and methods for reading and writing AppStream metadata"
8 url="https://people.freedesktop.org/~hughsient/appstream-glib/"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   curl
13   gtk3
14   libstemmer
15   libyaml
16   pacman
18 makedepends=(
19   git
20   gobject-introspection
21   gperf
22   gtk-doc
23   meson
25 provides=(
26   appdata-tools
27   libappstream-glib.so
29 conflicts=(appdata-tools)
30 replaces=(appdata-tools)
31 _commit=02c8ad3b66075d9b2c9094dff816cd44839a4b45  # tags/appstream_glib_0_8_2^0
32 source=("git+https://github.com/hughsie/appstream-glib#commit=$_commit")
33 b2sums=('SKIP')
35 pkgver() {
36   cd $pkgname
37   git describe --tags | sed 's/^appstream_glib_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
40 prepare() {
41   cd $pkgname
44 build() {
45   local meson_options=(
46     -D alpm=true
47     -D gtk-doc=true
48     -D rpm=false
49   )
51   arch-meson $pkgname build "${meson_options[@]}"
52   meson compile -C build
55 check() {
56   meson test -C build --print-errorlogs
59 package() {
60   meson install -C build --destdir "$pkgdir"
63 # vim:set sw=2 sts=-1 et: