archrelease: copy trunk to testing-x86_64
[arch-packages.git] / dleyna-connector-dbus / trunk / PKGBUILD
blobd3fac78ceb0837093064632b2204cbc5ebb7a2a3
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=dleyna-connector-dbus
4 pkgver=0.4.1
5 pkgrel=1
6 pkgdesc="Provides a D-Bus API for the dLeyna services"
7 url="https://github.com/phako/dleyna-connector-dbus"
8 arch=(x86_64)
9 license=(LGPL2.1)
10 depends=(dleyna-core dbus)
11 makedepends=(git meson)
12 _commit=8629619f68703f46d059ce80c6ef68c914f06c83  # tags/v0.4.1^0
13 source=("git+https://github.com/phako/dleyna-connector-dbus#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^v//;s/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   meson install -C build --destdir "$pkgdir"