archrelease: copy trunk to testing-x86_64
[arch-packages.git] / glib-networking / repos / extra-x86_64 / PKGBUILD
blobb4c1d016dda957dfdeaecdda3dd5b11857a41784
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=glib-networking
4 pkgver=2.76.0
5 pkgrel=1
6 epoch=1
7 pkgdesc="Network extensions for GLib"
8 url="https://gitlab.gnome.org/GNOME/glib-networking"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(
12   glib2
13   gnutls
14   gsettings-desktop-schemas
15   libproxy
17 makedepends=(
18   git
19   meson
21 checkdepends=(ca-certificates)
22 _commit=eab226398f9872c381033f7cb3af43dcb66600f4  # tags/2.76.0^0
23 source=("git+https://gitlab.gnome.org/GNOME/glib-networking.git#commit=$_commit")
24 sha256sums=('SKIP')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 prepare() {
32   cd $pkgname
35 build() {
36   arch-meson $pkgname build
37   meson compile -C build
40 check() {
41   meson test -C build --print-errorlogs
44 package() {
45   meson install -C build --destdir "$pkgdir"
48 # vim:set sw=2 sts=-1 et: