archrelease: copy trunk to testing-x86_64
[arch-packages.git] / gnome-text-editor / trunk / PKGBUILD
blobf8ef52c71b346dbc3cd331db0b75703093669d9a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Fabian Bornschein <fabiscafe-cat-mailbox-dog-org>
4 pkgname=gnome-text-editor
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="A simple text editor for the GNOME desktop"
8 url="https://gitlab.gnome.org/GNOME/gnome-text-editor"
9 arch=(x86_64)
10 license=(GPL3)
11 depends=(
12   editorconfig-core-c
13   enchant
14   glib2
15   gtksourceview5
16   libadwaita
18 makedepends=(
19   appstream-glib
20   git
21   meson
22   yelp-tools
24 groups=(gnome)
25 _commit=2ed7d45ff481f5d0a2cda54e0ec75ce5a823f40e  # tags/44.0^0
26 source=("git+https://gitlab.gnome.org/GNOME/gnome-text-editor.git#commit=$_commit")
27 b2sums=('SKIP')
29 pkgver() {
30   cd $pkgname
31   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
34 prepare() {
35   cd $pkgname
38 build() {
39   local meson_options=(
40     -D bugreport_url="https://bugs.archlinux.org/"
41   )
43   arch-meson $pkgname build "${meson_options[@]}"
44   meson compile -C build
47 check() {
48   meson test -C build --print-errorlogs
51 package() {
52   meson install -C build --destdir "$pkgdir"
55 # vim:set sw=2 sts=-1 et: