archrelease: copy trunk to testing-x86_64
[arch-packages.git] / hyphen-de / trunk / PKGBUILD
blob0b08c04c54eaf03d8fda37b5f5b2b2eac9f07d2f
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=hyphen-de
4 # https://cgit.freedesktop.org/libreoffice/dictionaries/log/de
5 _commit=9e27d044d98e65f89af8c86df722a77be827bdc8 # last commit "de" subdir - 2022-09-23
6 pkgver=20220923
7 pkgrel=1
8 pkgdesc="German hyphenation rules"
9 arch=(any)
10 url="https://wiki.documentfoundation.org/Development/Dictionaries"
11 license=('LGPL')
12 makedepends=('git')
13 optdepends=('hyphen: offers hyphenation library functions')
14 source=("git+https://anongit.freedesktop.org/git/libreoffice/dictionaries.git#commit=$_commit")
15 sha256sums=('SKIP')
17 #build() {
18 #  /bin/true
21 package() {
22   cd dictionaries/de
23   install -dm755 "${pkgdir}"/usr/share/hyphen
24   cp -p hyph_de_??.* "$pkgdir"/usr/share/hyphen
26   pushd "$pkgdir"/usr/share/hyphen/
27   de_DE_aliases="de_BE de_LU"
28   for lang in $de_DE_aliases; do
29         ln -s hyph_de_DE.dic hyph_$lang.dic
30   done
31   de_CH_aliases="de_LI"
32   for lang in $de_CH_aliases; do
33         ln -s hyph_de_CH.dic hyph_$lang.dic
34   done
36   popd
38   # the symlinks
39   install -dm755 "${pkgdir}"/usr/share/myspell/dicts
40   pushd "$pkgdir"/usr/share/myspell/dicts
41     for file in "$pkgdir"/usr/share/hyphen/*; do
42       ln -sv /usr/share/hyphen/$(basename $file) .
43     done
44   popd
45   
46   # docs
47   install -dm755 "${pkgdir}"/usr/share/doc/$pkgname
48   cp -p README_hyph_de.txt "$pkgdir"/usr/share/doc/$pkgname