archrelease: copy trunk to testing-x86_64
[arch-packages.git] / libebml / trunk / PKGBUILD
blobd2c38d2e39758830170ec2bbb3a62477dfbb503d
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
3 # Contributor: 03/08/04 <lefungus@altern.org>
5 pkgname=libebml
6 pkgver=1.4.4
7 pkgrel=1
8 pkgdesc='Extensible Binary Meta Language library'
9 arch=(x86_64)
10 url=https://github.com/Matroska-Org/libebml
11 license=(LGPL2.1)
12 depends=(gcc-libs)
13 makedepends=(
14   cmake
15   git
16   ninja
18 provides=(libebml.so)
19 _tag=8330b222fec992b295c8b2149cf70f9ff648ce4a
20 source=(git+https://github.com/Matroska-Org/libebml.git#tag=${_tag})
21 b2sums=(SKIP)
23 pkgver() {
24   cd libebml
25   git describe --tags | sed 's/^release-//'
28 build() {
29   cmake -S libebml -B build -G Ninja \
30     -DCMAKE_INSTALL_PREFIX=/usr \
31     -DCMAKE_INSTALL_LIBDIR=/usr/lib \
32     -DBUILD_SHARED_LIBS=ON
33   cmake --build build
36 package() {
37   DESTDIR="${pkgdir}" cmake --install build
40 # vim: ts=2 sw=2 et: