archrelease: copy trunk to testing-x86_64
[arch-packages.git] / libkolabxml / trunk / PKGBUILD
blobf800a698f39e8742786ce33ee220c6d711a08170
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=libkolabxml
5 pkgver=1.2.1
6 pkgrel=2
7 pkgdesc="Kolab XML Format Schema Definitions Library"
8 url='https://www.kolab.org/'
9 arch=('x86_64')
10 license=('GPL')
11 depends=('xerces-c' 'boost-libs')
12 makedepends=('cmake' 'boost' 'xsd' 'swig')
13 source=(https://cgit.kolab.org/libkolabxml/snapshot/libkolabxml-libkolabxml-$pkgver.tar.gz)
14 sha512sums=('a4967d84b57d4c637dcc36383f05dbb20fe2ba5e590235eac219ece33e15d29f5eb51e9501a4f9e277900fdec18ddd390e6dc564bf79663bb3513de07f04d39a')
16 build() {
17   cmake -B build -S $pkgname-$pkgname-$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -DBUILD_TESTS=OFF \
20     -DBoost_NO_BOOST_CMAKE=ON
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build