1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
11 pkgdesc="Library for sending desktop notifications"
12 url="https://gitlab.gnome.org/GNOME/libnotify"
25 _commit=69aff6e5fa2842e00b409c348bd73188548828b3 # tags/0.8.2^0
26 source=("git+$url.git#commit=$_commit")
31 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
39 arch-meson $pkgname build
40 meson compile -C build
44 meson test -C build --print-errorlogs
49 libg{lib,object,io}-2.0.so
52 provides=(libnotify.so)
54 meson install -C build --destdir "$pkgdir"
56 mkdir -p doc/usr/share
57 mv {"$pkgdir",doc}/usr/share/doc
60 package_libnotify-docs() {
61 pkgdesc+=" (documentation)"
67 # vim:set sw=2 sts=-1 et: