archrelease: copy trunk to testing-x86_64
[arch-packages.git] / orca / trunk / PKGBUILD
blob0a30f47c0927c5f2cae509bfd74c6a0a8f6f38ba
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: William Rea <sillywilly@gmail.com>
5 pkgname=orca
6 pkgver=44.0
7 pkgrel=2
8 pkgdesc="Screen reader for individuals who are blind or visually impaired"
9 url="https://wiki.gnome.org/Projects/Orca"
10 arch=(any)
11 license=(LGPL)
12 depends=(
13   at-spi2-core
14   brltty
15   gsettings-desktop-schemas
16   gst-plugins-base # playbin, audiotestsrc, basic decoders
17   gst-plugins-good # pulsesink, more decoders
18   gtk3
19   liblouis
20   libwnck3
21   python-atspi
22   python-setproctitle
23   speech-dispatcher
24   xorg-xkbcomp
25   xorg-xmodmap
27 makedepends=(
28   git
29   itstool
30   yelp-tools
32 groups=(gnome)
33 _commit=ceb644cf38cf84a7950460534d8843f2078fd83a  # tags/ORCA_44_0^0
34 source=("git+https://gitlab.gnome.org/GNOME/orca.git#commit=$_commit")
35 b2sums=('SKIP')
37 pkgver() {
38   cd orca
39   git describe --tags | sed 's/ORCA_//;s/_/\./g;s/[^-]*-g/r&/;s/-/+/g'
42 prepare() {
43   cd orca
44   NOCONFIGURE=1 ./autogen.sh
47 build() {
48   cd orca
49   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
50   make
53 package() {
54   cd orca
55   make DESTDIR="$pkgdir" install
58 # vim:set sw=2 sts=-1 et: