archrelease: copy trunk to testing-x86_64
[arch-packages.git] / perl-ffi-checklib / repos / extra-any / PKGBUILD
blob1f5015b7a9fe8e8dafed4fd310c9a8ae0822a009
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-ffi-checklib
4 pkgver=0.31
5 pkgrel=2
6 pkgdesc="Check that a library is available for FFI"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/FFI-CheckLib"
10 depends=('perl')
11 checkdepends=('perl-file-which' 'perl-test2-suite' 'perl-test2-tools-process')
12 options=('!emptydirs')
13 source=("https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/FFI-CheckLib-$pkgver.tar.gz")
14 sha512sums=('25dd359cbec5417baa2c3d6a1152fb8a50b9d1423f8adb1c9ebe4422aefaed6e3b9b73015c6960c5d69dbc151df50ecb5a8e365192a2108013b501433c52e1e2')
16 build() {
17   cd FFI-CheckLib-$pkgver
18   perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd FFI-CheckLib-$pkgver
24   make test
27 package() {
28   cd FFI-CheckLib-$pkgver
29   make DESTDIR="$pkgdir" install