archrelease: copy trunk to testing-x86_64
[arch-packages.git] / python-platformdirs / trunk / PKGBUILD
blob308419b23ac8249acf554eac896f153e47ec0379
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Tobias Roettger <toroettg@gmail.com>
4 pkgname=python-platformdirs
5 pkgver=3.5.0
6 pkgrel=2
7 pkgdesc='A small Python module for determining appropriate platform-specific dirs, e.g. a "user data dir"'
8 arch=('any')
9 url="https://github.com/platformdirs/platformdirs"
10 license=('MIT')
11 depends=('python-typing_extensions')
12 makedepends=('python-build' 'python-installer' 'python-hatchling' 'python-hatch-vcs')
13 checkdepends=('python-pytest-mock' 'python-appdirs')
14 source=("https://pypi.io/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz")
15 sha512sums=('2c454a760b3045f4824b1c436ac85533e7a6809e4525d70cee4d98289f9efc5a882384347a1992aaa237dc29ea8e778515eadeca208a2d058f9e574f5175ce20')
17 build() {
18   cd platformdirs-$pkgver
19   python -m build --wheel --no-isolation
22 check() {
23   cd platformdirs-$pkgver
24   PYTHONPATH="$PWD"/src pytest
27 package() {
28   cd platformdirs-$pkgver
29   python -m installer --destdir="$pkgdir/" dist/*.whl
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
33 # vim:set ts=2 sw=2 et: