1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Tobias Roettger <toroettg@gmail.com>
4 pkgname=python-platformdirs
7 pkgdesc='A small Python module for determining appropriate platform-specific dirs, e.g. a "user data dir"'
9 url="https://github.com/platformdirs/platformdirs"
11 depends=('python-typing_extensions')
12 makedepends=('python-build' 'python-installer' 'python-hatchling' 'python-hatch-vcs')
13 checkdepends=('python-pytest-mock' 'python-appdirs')
14 source=("https://pypi.io/packages/source/p/platformdirs/platformdirs-$pkgver.tar.gz")
15 sha512sums=('2c454a760b3045f4824b1c436ac85533e7a6809e4525d70cee4d98289f9efc5a882384347a1992aaa237dc29ea8e778515eadeca208a2d058f9e574f5175ce20')
18 cd platformdirs-$pkgver
19 python -m build --wheel --no-isolation
23 cd platformdirs-$pkgver
24 PYTHONPATH="$PWD"/src pytest
28 cd platformdirs-$pkgver
29 python -m installer --destdir="$pkgdir/" dist/*.whl
30 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
33 # vim:set ts=2 sw=2 et: