archrelease: copy trunk to testing-x86_64
[arch-packages.git] / qt6-scxml / trunk / PKGBUILD
blobd9fbdc4d640ff8fcb0a1c1c1750c768eb32709af
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-scxml
5 _qtver=6.5.0
6 pkgver=${_qtver/-/}
7 pkgrel=2
8 arch=(x86_64)
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Static and runtime integration of SCXML models into Qt6 code'
12 depends=(qt6-base)
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
15 groups=(qt6)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('f121843cb8cf4a76d621be371e80265ac28254f3c4c123b051e907c1c915766e')
20 build() {
21   cmake -B build -S $_pkgfn -G Ninja \
22     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname