archrelease: copy trunk to testing-x86_64
[arch-packages.git] / telly-skout / trunk / PKGBUILD
blob0362846e2da1ae49fb814a9ccd44a97d2d219a23
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=telly-skout
4 pkgver=23.04.0
5 pkgrel=1
6 pkgdesc='Convergent TV guide based on Kirigami'
7 url='https://apps.kde.org/telly-skout/'
8 arch=(x86_64)
9 license=(GPL LGPL)
10 groups=(kde-applications kde-utilities)
11 depends=(kirigami2 kcoreaddons kconfig ki18n kcrash)
12 makedepends=(extra-cmake-modules)
13 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('8241e862dacc6515db533329d16e50807f8cf0c778bc2394a6bf7c6dbaae1a91'
15             'SKIP')
16 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
17               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
18               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
20 build() {
21   cmake -B build -S $pkgname-$pkgver \
22     -DBUILD_TESTING=OFF
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build