db-move: moved evolution from [testing] to [extra] (x86_64)
[arch-packages.git] / dleyna-core / trunk / PKGBUILD
blob352bebbced2d5efcccbe4e359af2149d0806e65a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=dleyna-core
4 pkgver=0.7.0
5 pkgrel=3
6 pkgdesc="Library of utility functions that are used by the higher level dLeyna"
7 url="https://github.com/phako/dleyna-core"
8 arch=(x86_64)
9 license=(LGPL2.1)
10 depends=(gupnp)
11 makedepends=(git meson)
12 _commit=6fb250b19f774a7fb908e85926ec1c3a011e81d7  # tags/v0.7.0^0
13 source=("git+https://github.com/phako/dleyna-core#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^v//;s/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   meson compile -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   meson install -C build --destdir "$pkgdir"