db-move: moved evolution from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-keyring / repos / extra-x86_64 / PKGBUILD
blob689e4bf03f72561e4ab88a3f185bd471ddfd9aa9
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan De Groot <jgc@archlinux.org>
4 pkgname=gnome-keyring
5 pkgver=42.1
6 pkgrel=2
7 epoch=1
8 pkgdesc="Stores passwords and encryption keys"
9 url="https://wiki.gnome.org/Projects/GnomeKeyring"
10 arch=(x86_64)
11 license=(GPL LGPL)
12 depends=(gcr gcr-4 libcap-ng pam openssh)
13 makedepends=(git docbook-xsl python p11-kit)
14 provides=(org.freedesktop.secrets)
15 groups=(gnome)
16 install=gnome-keyring.install
17 options=(debug)
18 _commit=9d562e1e359e3ce01b61f0f52c75d38b96dece7b  # tags/42.1^0
19 source=("git+https://gitlab.gnome.org/GNOME/gnome-keyring.git#commit=$_commit"
20         0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch
21         0002-daemon-Add-Cinnamon-to-autostart-files.patch)
22 sha256sums=('SKIP'
23             '6985e3f7c60aa8dad794b1a9466f69737f3e9b5b7176e3888252c8c56647736a'
24             '91538221b304ef951a7d6d7441f8609a2787f725e55d60788b51e81f38c9012f')
26 pkgver() {
27   cd $pkgname
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 prepare() {
32   cd $pkgname
34   # Fix pkcs11 config dir
35   git apply -3 ../0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch
37   # Autolaunch in Cinnamon
38   git apply -3 ../0002-daemon-Add-Cinnamon-to-autostart-files.patch
40   NOCONFIGURE=1 ./autogen.sh
43 build() {
44   cd $pkgname
45   ./configure --prefix=/usr \
46     --sysconfdir=/etc \
47     --localstatedir=/var \
48     --libexecdir=/usr/lib \
49     --with-pam-dir=/usr/lib/security \
50     --disable-static \
51     --disable-schemas-compile
52   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
53   make
56 check() {
57   cd $pkgname
58   # Secure memory tests fail
59   dbus-run-session make -k check || :
62 package() {
63   cd $pkgname
64   make DESTDIR="$pkgdir" install