db-move: moved evolution from [testing] to [extra] (x86_64)
[arch-packages.git] / gnome-shell / trunk / PKGBUILD
blob9fa718adddcec1624a381dcc787be00617305d17
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Flamelab <panosfilip@gmail.com
5 pkgname=gnome-shell
6 pkgver=44.1
7 pkgrel=3
8 epoch=1
9 pkgdesc="Next generation desktop shell"
10 url="https://wiki.gnome.org/Projects/GnomeShell"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(
14   accountsservice
15   gcr-4
16   gjs
17   gnome-autoar
18   gnome-session
19   gnome-settings-daemon
20   gsettings-desktop-schemas
21   gtk4
22   libadwaita
23   libcanberra-pulse
24   libgdm
25   libgweather-4
26   libibus
27   libnma-gtk4
28   libsecret
29   libsoup3
30   mutter
31   unzip
32   upower
34 makedepends=(
35   asciidoc
36   bash-completion
37   evolution-data-server
38   git
39   gnome-control-center
40   gobject-introspection
41   gtk-doc
42   meson
43   sassc
45 checkdepends=(
46   appstream-glib
47   python-dbusmock
48   xorg-server-xvfb
50 optdepends=(
51   'evolution-data-server: Evolution calendar integration'
52   'gnome-bluetooth-3.0: Bluetooth support'
53   'gnome-control-center: System settings'
54   'gnome-disk-utility: Mount with keyfiles'
55   'gst-plugin-pipewire: Screen recording'
56   'gst-plugins-good: Screen recording'
57   'power-profiles-daemon: Power profile switching'
58   'switcheroo-control: Multi-GPU support'
60 groups=(gnome)
61 _commit=b0ca64e7775225b7c5d049571a44ef40bf516406  # tags/44.1^0
62 source=(
63   "git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
64   "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
66 b2sums=('SKIP'
67         'SKIP')
69 pkgver() {
70   cd $pkgname
71   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
74 prepare() {
75   cd $pkgname
77   git submodule init
78   git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
79   git -c protocol.file.allow=always submodule update
82 build() {
83   local meson_options=(
84     -D gtk_doc=true
85   )
87   CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
88   LDFLAGS+=" -Wl,-Bsymbolic-functions"
90   arch-meson $pkgname build "${meson_options[@]}"
91   meson compile -C build
94 _check() (
95   export XDG_RUNTIME_DIR="$PWD/rdir"
96   mkdir -p -m 700 "$XDG_RUNTIME_DIR"
98   meson test -C build --print-errorlogs -t 3
101 check() {
102   dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
103     bash -c "$(declare -f _check); _check"
106 package() {
107   depends+=(libmutter-12.so)
108   meson install -C build --destdir "$pkgdir"
111 # vim:set sw=2 sts=-1 et: