1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Flamelab <panosfilip@gmail.com
9 pkgdesc="Next generation desktop shell"
10 url="https://wiki.gnome.org/Projects/GnomeShell"
20 gsettings-desktop-schemas
51 'evolution-data-server: Evolution calendar integration'
52 'gnome-bluetooth-3.0: Bluetooth support'
53 'gnome-control-center: System settings'
54 'gnome-disk-utility: Mount with keyfiles'
55 'gst-plugin-pipewire: Screen recording'
56 'gst-plugins-good: Screen recording'
57 'power-profiles-daemon: Power profile switching'
58 'switcheroo-control: Multi-GPU support'
61 _commit=b0ca64e7775225b7c5d049571a44ef40bf516406 # tags/44.1^0
63 "git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
64 "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
71 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
78 git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
79 git -c protocol.file.allow=always submodule update
87 CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
88 LDFLAGS+=" -Wl,-Bsymbolic-functions"
90 arch-meson $pkgname build "${meson_options[@]}"
91 meson compile -C build
95 export XDG_RUNTIME_DIR="$PWD/rdir"
96 mkdir -p -m 700 "$XDG_RUNTIME_DIR"
98 meson test -C build --print-errorlogs -t 3
102 dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
103 bash -c "$(declare -f _check); _check"
107 depends+=(libmutter-12.so)
108 meson install -C build --destdir "$pkgdir"
111 # vim:set sw=2 sts=-1 et: