db-move: moved evolution from [testing] to [extra] (x86_64)
[arch-packages.git] / tinycompress / trunk / PKGBUILD
blob683779cbac8f4b45295dc33dbd01846e714b058d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=tinycompress
4 pkgver=1.2.8
5 pkgrel=2
6 pkgdesc="ALSA compressed device interface"
7 url="https://github.com/alsa-project/tinycompress"
8 arch=(x86_64)
9 license=(BSD LGPL2.1)
10 depends=(glibc)
11 makedepends=(ffmpeg git)
12 optdepends=("ffmpeg: fcplay utility")
13 provides=(libtinycompress.so)
14 options=(debug)
15 _commit=750ebbe68e48178fae1732aa169fdc8f46fec6fa  # tags/v1.2.8^0
16 source=("git+$url#commit=$_commit")
17 b2sums=('SKIP')
19 pkgver() {
20   cd tinycompress
21   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   mkdir -p build
27   cd tinycompress
28   ./autogen.sh
31 build() {
32   local configure_options=(
33     --prefix=/usr
34     --sysconfdir=/etc
35     --localstatedir=/var
36     --enable-fcplay
37   )
39   cd build
40   ../tinycompress/configure "${configure_options[@]}"
41   make
44 check() {
45   make -C build check
48 package() {
49   make -C build install DESTDIR="$pkgdir"
50   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 tinycompress/COPYING
53 # vim:set sw=2 sts=-1 et: