db-move: moved gnome-dictionary from [testing] to [extra] (x86_64)
[arch-packages.git] / telepathy-kde-accounts-kcm / trunk / PKGBUILD
blobe1e3e5bfc535f2751a7d59b04f34323b7c360866
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Laurent Carlier <lordheavym@gmail.com>
5 pkgname=telepathy-kde-accounts-kcm
6 _pkgname=ktp-accounts-kcm
7 pkgver=23.04.0
8 pkgrel=1
9 pkgdesc='KCM Module for configuring Telepathy Instant Messaging Accounts'
10 arch=(x86_64)
11 url='https://community.kde.org/KTp'
12 license=(GPL)
13 groups=(kde-applications kde-network telepathy-kde)
14 depends=(telepathy-qt kaccounts-providers)
15 makedepends=(extra-cmake-modules intltool)
16 optdepends=('telepathy-gabble: XMPP/Jabber accounts support' 'telepathy-haze: account types supported by Pidgin/libpurple'
17             'telepathy-morse: Telegram accounts support' 'telepathy-salut: link-local XMPP account support')
18 source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig})
19 sha256sums=('960bc75fa84fbc508a32507ad033d66cd1c15df7dab2ebba6d52afa15975c1b4'
20             'SKIP')
21 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
22               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
23               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
25 build() {
26   cmake -B build -S $_pkgname-$pkgver \
27     -DBUILD_TESTING=OFF
28   cmake --build build
31 package() {
32   DESTDIR="$pkgdir" cmake --install build