db-move: moved gnome-dictionary from [testing] to [extra] (x86_64)
[arch-packages.git] / xf86-video-sisusb / trunk / PKGBUILD
bloba152e1e7b373d6b1ca666f66cef4f9929a521cc8
1 #Maintainer: Jan de Groot <jgc@archlinux.org>
3 pkgname=xf86-video-sisusb
4 pkgver=0.9.7
5 pkgrel=4
6 pkgdesc="X.org SiS USB video driver"
7 arch=(x86_64)
8 url="https://xorg.freedesktop.org/"
9 license=('custom')
10 depends=('glibc')
11 makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=25.2')
12 conflicts=('xorg-server<21.1.1' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
13 source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2)
14 sha256sums=('f4400416b920cd1136d60d36b99d33f245cdeaf2ad6c1340936c7c0987761424')
16 build() {
17   cd ${pkgname}-${pkgver}
19   # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
20   # With them, module fail to load with undefined symbol.
21   # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
22   export CFLAGS=${CFLAGS/-fno-plt}
23   export CXXFLAGS=${CXXFLAGS/-fno-plt}
24   export LDFLAGS=${LDFLAGS/,-z,now}
26   ./configure --prefix=/usr
27   make
30 package() {
31   cd ${pkgname}-${pkgver}
32   make DESTDIR="${pkgdir}" install
33   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
34   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"