1 # Maintainer: Daniel Isenmann <daniel [at] archlinux.org>
2 # Contributor: dorphell <dorphell@gmx.net>
7 pkgdesc="A garbage collector for C and C++"
9 url="https://www.hboehm.info/gc/"
12 source=(https://github.com/ivmai/bdwgc/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz
13 gc-missing-header.patch::https://github.com/ivmai/bdwgc/commit/c876dc2b.patch)
14 sha512sums=('ff781360bca667f1f95fbfed073e9035f63134cac1bda4f7e4217664a3713c2846f750a3ce92732972c0435c69355b051f6e8eb6f2698b0d48d9107ff960bacf'
15 '489c121556d6a6fa25da8751676d39179643bfd187cb9f216a095ce606a43790e9348b5b2b7dded76650b33df61078c457150776532d08491a7f09e5a57013a8')
19 patch -p1 < ../gc-missing-header.patch # Install missing header
24 cd ${pkgname}-${pkgver}
25 ./configure --prefix=/usr --enable-cplusplus --disable-static
26 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
31 cd ${pkgname}-${pkgver}
36 cd ${pkgname}-${pkgver}
37 make DESTDIR="${pkgdir}" install
38 sed 's|GC_MALLOC 1L|gc 3|g' doc/gc.man |
39 install -Dm644 /dev/stdin "${pkgdir}/usr/share/man/man3/gc.3"