archrelease: copy trunk to extra-x86_64
[arch-packages.git] / geeqie / repos / testing-x86_64 / PKGBUILD
blob09a8965a2ed3042f111210989eda55e6b945a6d5
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
3 # Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
5 pkgname=geeqie
6 pkgver=2.0
7 pkgrel=1
8 pkgdesc='Lightweight image viewer'
9 arch=('x86_64')
10 url="http://www.geeqie.org/"
11 license=('GPL2')
12 # https://github.com/BestImageViewer/geeqie#optional-libraries
13 depends=('exiv2' 'gtk3' 'ffmpegthumbnailer'
14          'djvulibre' 'libheif' 'libchamplain'
15          'poppler-glib' 'libarchive' 'libraw' 'lua53'
16          'libjxl' 'gspell')
17 makedepends=('meson'
18              'intltool' 'python' 'librsvg'
19              'highway' 'vim'
20              'libwmf' 'libwebp' 'imagemagick'
21              'fbida' 'gawk' 'perl-image-exiftool'
22              # for the docs
23              'doxygen' 'yelp-tools' 'graphviz'
25 optdepends=('librsvg: SVG rendering'
26             'fbida: for jpeg rotation'
27             'gawk: to use the geo-decode function'
28             'perl-image-exiftool: for the jpeg extraction plugin'
29             'gphoto2: command-line tools for various (plugin) operations'
30             'imagemagick: command-line tools for various (plugin) operations')
31 options=('debug')
32 source=(#"http://www.geeqie.org/${pkgname}-${pkgver}.tar.xz"{,.asc}
33         https://github.com/BestImageViewer/geeqie/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz{,.asc}
35 sha256sums=('27d803d72518913a75f3a2c65909fdca9f34037fdbfd493bee1a4e63dba9f76d'
36             'SKIP')
37 validpgpkeys=('91EC400226201276E2ADCEC7D0DA6F44C936D1DA') # "Colin Clark <colin.clark@cclark.uk>"
39 # main repo: http://www.geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git
40 # bug tracker: https://github.com/BestImageViewer/geeqie/issues
42 build() {
43   arch-meson $pkgname-$pkgver build
44   meson compile -C build
47 check() {
48   meson test -C build
51 package(){
52   DESTDIR="$pkgdir" meson install -C build