archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kdevelop / kde-unstable / PKGBUILD
blobf32fdf9ef274086df83375a7647115bfc3a8c93c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
5 pkgname=kdevelop
6 pkgver=22.07.90
7 _clangver=14.0.6
8 pkgrel=1
9 pkgdesc='C++ IDE using KDE technologies'
10 arch=(x86_64)
11 url='http://www.kdevelop.org/'
12 license=(GPL)
13 depends=(clang=$_clangver libksysguard kitemmodels knotifyconfig ktexteditor grantlee libkomparediff2 kcmutils threadweaver)
14 makedepends=(extra-cmake-modules kdoctools kdevelop-pg-qt llvm qt5-tools plasma-framework krunner okteta boost purpose subversion astyle)
15 optdepends=('konsole: embedded terminal'
16             'git: Git support' 'subversion: SVN support'
17             'gdb: GNU debugger support' 'lldb: LLDB debugger support'
18             'qt5-doc: Qt documentation integration'
19             'cmake: cmake integration'
20             'meson: meson integration'
21             'qt5-tools: qthelp plugin'
22             'okteta: GNU debugger support'
23             'plasma-framework: for the plasma addons'
24             'purpose: patch review plugin'
25             'astyle: astyle plugin'
26             'cppcheck: code analyzer' 'heaptrack: memory profiler'
27             'clazy: clazy analyzer plugin'
28             'kio-extras: man pages plugin')
29 conflicts=(kdevelop-qmljs kdevplatform)
30 replaces=(kdevelop-qmljs kdevplatform kdevelop-clang-tidy)
31 groups=(kde-applications kdevelop)
32 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
33 sha256sums=('7b3d6fe0f477b3d26e9f1d27621225443d76f87e3c2272dba665c8330abb8b7f'
34             'SKIP')
35 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
36               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
37               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
38 options=(debug)
40 build() {
41   cmake -B build -S $pkgname-$pkgver \
42     -DBUILD_TESTING=OFF
43   cmake --build build
46 package() {
47   DESTDIR="$pkgdir" cmake --install build