archrelease: copy trunk to extra-x86_64
[arch-packages.git] / khealthcertificate / trunk / PKGBUILD
blobfe3a5a58478235f31831cf7bb812c3863dacb4e0
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=khealthcertificate
4 pkgver=22.06
5 pkgrel=1
6 pkgdesc='Handling of digital vaccination, test and recovery certificates'
7 arch=(x86_64)
8 url='https://www.kde.org'
9 license=(LGPL)
10 depends=(karchive kcodecs)
11 makedepends=(extra-cmake-modules qt5-declarative)
12 optdepends=('qt5-declarative: QML bindings')
13 source=(https://download.kde.org/stable/plasma-mobile/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('d0223a1b701d8133e1db92451b378e3815dca54658c01985d18ec1205c4b321d'
15             'SKIP')
16 validpgpkeys=(0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D) # Bhushan Shah (mykolab address) <bshah@mykolab.com>
18 build() {
19   cmake -B build -S $pkgname-$pkgver \
20     -DBUILD_TESTING=OFF
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build