archrelease: copy trunk to extra-x86_64
[arch-packages.git] / konversation / kde-unstable / PKGBUILD
blob341aec798ed122bd794950b6cd460ea8b1b6f192
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
4 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 # Contributor: James Rayner <iphitus@gmail.com>
6 # Contributor: Sergio Jovani Guzman <moret@paretux.org>
8 pkgname=konversation
9 pkgver=22.07.90
10 pkgrel=1
11 pkgdesc='A user-friendly and fully-featured IRC client'
12 arch=(x86_64)
13 url='https://apps.kde.org/konversation/'
14 depends=(knotifyconfig kparts kidletime knewstuff qca-qt5 hicolor-icon-theme perl)
15 optdepends=('python: python scripting support' 'keditbookmarks: for managing bookmarks')
16 makedepends=(extra-cmake-modules kdoctools)
17 license=(GPL2 FDL)
18 groups=(kde-applications kde-network)
19 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
20 sha256sums=('1eb8dba1d2387fee7de1831f78497dd2f28b725358b0472e1a07702e1eb2e760'
21             'SKIP')
22 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
23               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
24               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
25 options=(debug)
27 build() {
28   cmake -B build -S $pkgname-$pkgver \
29     -DBUILD_TESTING=OFF
30   cmake --build build
33 package() {
34   DESTDIR="$pkgdir" cmake --install build