archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libwpe / repos / extra-x86_64 / PKGBUILD
blob195d0205c84849ac5e6b3942b381fe65b115c008
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=libwpe
4 pkgver=1.12.2
5 pkgrel=1
6 pkgdesc="General-purpose library for WPE WebKit"
7 url="https://wpewebkit.org"
8 arch=(x86_64)
9 license=(custom)
10 depends=(libxkbcommon gcc-libs)
11 makedepends=(mesa git meson)
12 provides=(libwpe-1.0.so)
13 options=(debug)
14 _commit=f43cb10b6c428555ed999bb0811e46afe7395d96  # tags/1.12.2^0
15 source=("git+https://github.com/WebPlatformForEmbedded/libwpe?signed#commit=$_commit")
16 sha256sums=('SKIP')
17 validpgpkeys=('5AA3BC334FD7E3369E7C77B291C559DBE4C9123B') # Adrián Pérez de Castro <aperez@igalia.com>
19 pkgver() {
20   cd libwpe
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd libwpe
28 build() {
29   arch-meson libwpe build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"
39   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 libwpe/COPYING
42 # vim:set sw=2 et: