1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-editdistance
6 pkgdesc="Fast implementation of the edit distance(Levenshtein distance)"
9 url="https://github.com/aflc/editdistance"
11 makedepends=('python-setuptools')
12 checkdepends=('python-nose')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/aflc/editdistance/archive/v$pkgver.tar.gz"
15 sha512sums=('1b2b0a23edc752564ddb19f7625e227fc7ea5b6e838da014effdec0edbcca2f2ad02460817638e7ea6d5857f71e3eb8af6fd94d936e6d26fe1d7dcad446ea573'
16 '590232c1e7fa5aaaaa77573c4ea23533522177ca0ac07a0ce7f00e446d47467df2e19936ecb5e057fddc664d1daca39e2217cb5f6e3192ef5edf49b1f73e0f10')
19 cd editdistance-$pkgver
24 cd editdistance-$pkgver
25 python setup.py nosetests
29 cd editdistance-$pkgver
30 python setup.py install --root="$pkgdir" --optimize=1
31 install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE