archrelease: copy trunk to extra-x86_64
[arch-packages.git] / sdl2_mixer / trunk / PKGBUILD
bloba9b926cb0d8261717102b2f7e5ef262968b064ea
1 # Maintainer: Sven-Hendrik Haase <svenstaro@archlinux.org>
2 pkgname=sdl2_mixer
3 pkgver=2.6.1
4 pkgrel=1
5 pkgdesc="A simple multi-channel audio mixer (Version 2)"
6 arch=('x86_64')
7 url="https://github.com/libsdl-org/SDL_mixer"
8 license=('MIT')
9 depends=('sdl2' 'libvorbis' 'libmodplug' 'mpg123' 'flac' 'opusfile')
10 makedepends=('fluidsynth')
11 optdepends=('fluidsynth: MIDI software synth, replaces built-in timidity')
12 source=("https://github.com/libsdl-org/SDL_mixer/releases/download/release-${pkgver}/SDL2_mixer-${pkgver}.tar.gz"{,.sig})
13 sha512sums=('2e8ce354d2b87b3f7a44f4103f4e23f519e51ed8788c4032ef8af4f01c9cbe6366b2ae935e1f5ba334d212f8db07c2909e6923d622d8a3443f35c9c8fbf155cc'
14             'SKIP')
15 validpgpkeys=('1528635D8053A57F77D1E08630A59377A7763BE6')
17 build() {
18   cd "${srcdir}/SDL2_mixer-${pkgver}/"
20   ./configure --disable-static --prefix=/usr
21   make
24 package() {
25   cd "${srcdir}/SDL2_mixer-${pkgver}/"
27   make DESTDIR="${pkgdir}" install
28   install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"