archrelease: copy trunk to extra-x86_64
[arch-packages.git] / uhttpmock / trunk / PKGBUILD
blobbed40eddcacbf1faa96a2cd66ba7ae1b0d1d1482
1 # Maintainer:
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=uhttpmock
5 pkgver=0.5.5
6 pkgrel=1
7 pkgdesc="HTTP web service mocking project for projects which use libsoup"
8 url="https://gitlab.freedesktop.org/pwithnall/uhttpmock"
9 depends=('glib2' 'libsoup')
10 makedepends=('meson' 'gtk-doc')
11 license=('LGPL2.1')
12 arch=(x86_64)
13 source=(https://gitlab.freedesktop.org/pwithnall/uhttpmock/-/archive/$pkgver/uhttpmock-$pkgver.tar.gz)
14 sha256sums=('61e812c33f15ecd840ebe729cf10727142c1ef0244b589fd82be7d1f9f19b8fe')
16 build() {
17   meson build $pkgname-$pkgver \
18     --prefix=/usr \
19     -D introspection=false
20   meson compile -C build
23 package() {
24   meson install -C build --destdir="$pkgdir"