archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xfce4-sensors-plugin / trunk / PKGBUILD
blob97fcd2bdd0bf0475bec9bdff0291c9fbc06c9a91
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Andreas Radke <andyrtr@archlinux.org>
3 # Contributor: Merk Matthias <macem@chello.at>
5 pkgname=xfce4-sensors-plugin
6 pkgver=1.4.3
7 pkgrel=1
8 pkgdesc="Sensors plugin for the Xfce panel"
9 arch=('x86_64')
10 url="https://docs.xfce.org/panel-plugins/xfce4-sensors-plugin"
11 license=('GPL2')
12 groups=('xfce4-goodies')
13 depends=('xfce4-panel' 'lm_sensors' 'libnotify' 'hicolor-icon-theme')
14 makedepends=('intltool' 'hddtemp' 'netcat')
15 optdepends=('hddtemp: for monitoring the temperature of hard drives')
16 source=(https://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2)
17 sha256sums=('171c0235f70c65f0ffee587e960d9da79b284855df22130239eac26272ec06c9')
19 build() {
20   cd "$srcdir/$pkgname-$pkgver"
22   ./configure \
23     --prefix=/usr \
24     --sysconfdir=/etc \
25     --libexecdir=/usr/lib \
26     --localstatedir=/var \
27     --datadir=/usr/share \
28     --datarootdir=/usr/share \
29     --disable-static \
30     --disable-debug \
31     --disable-pathchecks
32   make
35 package() {
36   cd "$srcdir/$pkgname-$pkgver"
37   make DESTDIR="$pkgdir" install
40 # vim:set ts=2 sw=2 et: