1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
7 pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer"
8 url="https://blogs.gnome.org/clutter/"
11 depends=(mesa libdrm libxext libxdamage libxcomposite gdk-pixbuf2 pango
13 makedepends=(gobject-introspection git gtk-doc)
14 provides=(libcogl.so libcogl-{gles2,pango,path}.so)
15 _commit=c2e25cef6bd7b3f12c8625f82956388e419cd046 # tags/1.22.8^0
16 source=("git+https://gitlab.gnome.org/GNOME/cogl.git#commit=$_commit")
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 NOCONFIGURE=1 ./autogen.sh
31 ./configure --prefix=/usr \
33 --enable-{kms,wayland}-egl-platform \
34 --enable-wayland-egl-server
36 # https://bugzilla.gnome.org/show_bug.cgi?id=655517
37 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
44 make DESTDIR="$pkgdir" install