db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / findutils / trunk / PKGBUILD
blobe5e88f19d1e83d33b85fdf2d66d28ac790e237e5
1 # Maintainer:
3 pkgname=findutils
4 pkgver=4.9.0
5 pkgrel=3
6 pkgdesc="GNU utilities to locate files"
7 arch=('x86_64')
8 license=('GPL3')
9 depends=('glibc' 'sh')
10 url='https://www.gnu.org/software/findutils/'
11 source=("https://ftp.gnu.org/pub/gnu/findutils/${pkgname}-${pkgver}.tar.xz"{,.sig})
12 sha256sums=('a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe'
13             'SKIP')
14 validpgpkeys=('A5189DB69C1164D33002936646502EF796917195') # Bernhard Voelker <mail@bernhard-voelker.de>
16 build() {
17   cd ${pkgname}-${pkgver}
19   # Don't build or install locate because we use mlocate,
20   # which is a secure version of locate.
21   sed -e '/^SUBDIRS/s/locate//' -e 's/frcode locate updatedb//' -i Makefile.in
23   ./configure --prefix=/usr
24   # don't build locate, but the docs want a file in there.
25   make -C locate dblocation.texi
26   make
29 check() {
30   cd ${pkgname}-${pkgver}
31   make check
34 package() {
35   cd ${pkgname}-${pkgver}
36   make DESTDIR="$pkgdir" install