db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / fluidsynth / repos / extra-x86_64 / PKGBUILD
blob6df7fc864515e52f9f9a27df828f459f3c52c68b
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Ray Rashif <schiv@archlinux.org>
3 # Contributor: damir <damir@archlinux.org>
5 pkgname=fluidsynth
6 pkgver=2.3.2
7 pkgrel=1
8 pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
9 arch=(x86_64)
10 url="https://www.fluidsynth.org/"
11 license=(LGPL2.1)
12 groups=(pro-audio)
13 depends=(
14   gcc-libs
15   glibc
16   sdl2
18 makedepends=(
19   alsa-lib
20   cmake
21   dbus
22   doxygen
23   glib2
24   jack
25   ladspa
26   libinstpatch
27   libpipewire
28   libpulse
29   libsndfile
30   portaudio
31   readline
32   systemd-libs
34 provides=(
35   libfluidsynth.so
36   soundfont-synthesizer
38 backup=(etc/conf.d/$pkgname)
39 source=($pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz)
40 sha512sums=('21798b5a80a7edd8ef02b983d9b230af45cc66b98b32d593228e12dbec15b12c6cf6c0f3692c12af66de1ba2049fa9d6ad2b68c7d1579347eec14d24870b0025')
41 b2sums=('2d88e52223ff9c6bc5bcbcd8b15f30abb12632202b9a5c5eecc5eb95620aeaa2d7d9b80b76e6b26eef95ca92521bdc9e6d539f8235d90ca0429b12bb72db1a6f')
43 build() {
44   local cmake_options=(
45     -B build
46     -D CMAKE_BUILD_TYPE=None
47     -D CMAKE_INSTALL_PREFIX=/usr
48     -D FLUID_DAEMON_ENV_FILE=/etc/conf.d/fluidsynth
49     -D LIB_SUFFIX=""
50     -D enable-ladspa=ON
51     -D enable-portaudio=ON
52     -S $pkgname-$pkgver
53     -W no-dev
54   )
56   cmake "${cmake_options[@]}"
57   cmake --build build --verbose
60 check() {
61   make check -k -C build
64 package() {
65   depends+=(
66     alsa-lib libasound.so
67     dbus libdbus-1.so
68     glib2 libglib-2.0.so libgmodule-2.0.so libgobject-2.0.so
69     jack libjack.so
70     libinstpatch libinstpatch-1.0.so
71     libpipewire libpipewire-0.3.so
72     libpulse libpulse-simple.so
73     libsndfile libsndfile.so
74     portaudio libportaudio.so
75     readline libreadline.so
76     systemd-libs libsystemd.so
77   )
79   DESTDIR="$pkgdir" cmake --install build
80   install -vDm 644 build/$pkgname.service -t "$pkgdir/usr/lib/systemd/user/"
81   install -vDm 644 build/$pkgname.conf "$pkgdir/etc/conf.d/$pkgname"
82   install -vDm 644 $pkgname-$pkgver/{AUTHORS,ChangeLog,{CONTRIBUTING,README}.md,THANKS,TODO} -t "$pkgdir/usr/share/doc/$pkgname/"