db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / layer-shell-qt / trunk / PKGBUILD
blob53f1379a6730b7dff1b8fc31dba6bc61af292fb1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=layer-shell-qt
4 pkgver=5.27.4
5 _dirver=$(echo $pkgver | cut -d. -f1-3)
6 pkgrel=1
7 pkgdesc='Qt component to allow applications to make use of the Wayland wl-layer-shell protocol'
8 arch=(x86_64)
9 url='https://kde.org/plasma-desktop/'
10 license=(GPL LGPL)
11 source=(https://download.kde.org/stable/plasma/$_dirver/$pkgname-$pkgver.tar.xz{,.sig})
12 depends=(qt5-wayland)
13 makedepends=(extra-cmake-modules wayland-protocols)
14 groups=(plasma)
15 sha256sums=('3b3aedc14b23023c8e8a4e5d0a16711f24b505cd8a2f470baf595a6ed0e3d0fe'
16             'SKIP')
17 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
18               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
19               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
20               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
22 build() {
23   cmake -B build -S $pkgname-$pkgver
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build