db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / libots / repos / extra-x86_64 / PKGBUILD
blobd081e5830095c6bb915feb55ee24e92572fd32f8
1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=libots
5 pkgver=0.5.0
6 pkgrel=6
7 pkgdesc='Open Text Summarizer'
8 url='https://libots.sourceforge.net/'
9 arch=('x86_64')
10 license=('GPL')
11 depends=('libxml2' 'glib2' 'popt')
12 source=("https://sources.archlinux.org/other/packages/libots/ots-$pkgver.tar.gz"
13         libots-fix-build.patch)
14 sha256sums=('ea908d22256166d1200fef55a82dd3ea8e096a249eaaf0b926f3577f1a63e137'
15             '0c5033302ffe8d87dd2f85745ea2a531ac573a901302d1b15bf51a3327102f6a')
17 prepare() {
18   cd ots-${pkgver}
19   touch gtk-doc.make
20   sed 's/en.xml$//' -i dic/Makefile.am
21   patch -p1 -i ../libots-fix-build.patch # Fix makefile dependencies (Debian)
22   libtoolize --force
23   aclocal
24   automake --add-missing --force
25   autoconf
28 build() {
29   cd ots-${pkgver}
30   ./configure --prefix=/usr
31   make -j1
34 package() {
35   cd ots-${pkgver}
36   make DESTDIR="${pkgdir}" install