db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / python-packaging / trunk / PKGBUILD
blob3e5ac1adb74fe891f8dbc7f028b7e576d79eadd3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-packaging
4 pkgver=23.0
5 pkgrel=3
6 pkgdesc="Core utilities for Python packages"
7 arch=('any')
8 url="https://github.com/pypa/packaging"
9 license=('Apache')
10 depends=('python')
11 makedepends=('python-build' 'python-installer' 'python-flit-core')
12 checkdepends=('python-pytest' 'python-pretend')
13 source=("https://github.com/pypa/packaging/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('5dd2f4a596e5a1ed01b461a37e063573f5ae08e181df40377a167fe2483205b3d965e10dc403cd173d0f87e0bdcae3cde05bd39024783fbe44541d0f777d94de')
16 build() {
17   cd packaging-$pkgver
18   python -m build -nw
21 check() {
22   cd packaging-$pkgver
23   PYTHONPATH=src pytest
26 package() {
27   cd packaging-$pkgver
28   python -m installer --destdir="$pkgdir" dist/*.whl