db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / swell-foop / trunk / PKGBUILD
blob383d0c7cb3f5e996644eef6c3fc1f5cb163fd5aa
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=swell-foop
5 pkgver=41.1
6 pkgrel=1
7 pkgdesc="Clear the screen by removing groups of colored and shaped tiles"
8 url="https://wiki.gnome.org/Apps/Swell%20Foop"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(clutter-gtk librsvg libgnome-games-support libgee)
12 makedepends=(yelp-tools appstream-glib vala git meson)
13 groups=(gnome-extra)
14 _commit=f89d9cfe7c4b73ae37cf5ed0a6bdc9060365e55d  # tags/41.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/swell-foop.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"