db-move: moved xdg-desktop-portal-gnome from [testing] to [extra] (x86_64)
[arch-packages.git] / x264 / trunk / PKGBUILD
blob134142f774359e15f7b4662625efd8ad815c9f13
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
4 # Contributor: damir <damir@archlinux.org>
5 # Contributor: Paul Mattal <paul@archlinux.org>
7 pkgname=x264
8 pkgver=0.164.r3095.baee400
9 pkgrel=4
10 epoch=3
11 pkgdesc='Open Source H264/AVC video encoder'
12 arch=(x86_64)
13 url=https://www.videolan.org/developers/x264.html
14 license=(GPL)
15 depends=(liblsmash.so)
16 makedepends=(
17   git
18   nasm
20 provides=(
21   libx264
22   libx264.so
24 conflicts=(
25   libx264
26   libx264-10bit
27   libx264-all
29 replaces=(
30   libx264
31   libx264-10bit
32   libx264-all
34 _commit=baee400fa9ced6f5481a728138fed6e867b0ff7f  # master
35 source=(git+https://code.videolan.org/videolan/x264.git#commit=${_commit})
36 sha256sums=(SKIP)
38 pkgver() {
39   cd x264
40   ./version.sh | grep X264_POINTVER | sed -r 's/^#define X264_POINTVER "([0-9]+\.[0-9]+)\.([0-9]+) (.*)"$/\1.r\2.\3/'
43 build() {
44   cd x264
45   ./configure \
46     --prefix=/usr \
47     --enable-shared \
48     --enable-pic \
49     --enable-lto \
50     --disable-avs
51   make
54 package() {
55   make -C x264 DESTDIR="${pkgdir}" BASHCOMPLETIONSDIR="/usr/share/bash-completion/completions" install-cli install-lib-shared install-bashcompletion
58 # vim: ts=2 sw=2 et: