OCaml 4.13.1 rebuild
[arch-packages.git] / dconf-editor / repos / extra-x86_64 / PKGBUILD
blob51817180112cc48468f0ee5e34f3d415482f3284
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=dconf-editor
4 pkgver=3.38.3
5 pkgrel=1
6 pkgdesc="dconf Editor"
7 arch=(x86_64)
8 url="https://wiki.gnome.org/Projects/dconf"
9 license=(GPL3)
10 groups=(gnome-extra)
11 depends=(gtk3 dconf)
12 makedepends=(vala meson git)
13 _commit=886181423ba8e93e766087425a0f2066f450cab1  # tags/3.38.3^0
14 source=("git+https://gitlab.gnome.org/GNOME/dconf-editor.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   DESTDIR="$pkgdir" meson install -C build
39 # vim:set ts=2 sw=2 et: