1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Daniel Isenmann <daniel@archlinux.org>
7 pkgdesc='GNU Image Manipulation Program'
8 url='https://www.gimp.org/'
10 license=('GPL' 'LGPL')
11 depends=('babl' 'dbus-glib' 'desktop-file-utils' 'gegl' 'glib-networking' 'hicolor-icon-theme'
12 'openjpeg2' 'lcms2' 'libheif' 'libexif' 'libgudev' 'libmng' 'libmypaint' 'librsvg' 'libwebp'
13 'libwmf' 'libxmu' 'libxpm' 'mypaint-brushes1' 'openexr' 'poppler-data' 'gtk2' 'graphviz')
14 makedepends=('alsa-lib' 'curl' 'ghostscript' 'gtk-doc' 'intltool' 'iso-codes' 'poppler-glib')
15 optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
16 'poppler-glib: for pdf support'
17 'alsa-lib: for MIDI event controller module'
18 'curl: for URI support'
19 'ghostscript: for postscript support')
20 conflicts=('gimp-plugin-wavelet-decompose')
21 replaces=('gimp-plugin-wavelet-decompose')
23 source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
24 0001-no-check-update.patch
26 sha256sums=('4f4dc22cff1ab5f026feaa2ab55e05775b3a11e198186b47bdab79cbfa078826'
27 'ac3e8b44cf391f4ab3050652f2cc1f146f451fb25178d5a596d905f5bad13fcf'
28 '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
31 cd ${pkgname}-${pkgver}
33 patch -Np1 < ../0001-no-check-update.patch
38 pkg-config --exists --print-errors "OpenEXR >= 1.6.1"
39 cd ${pkgname}-${pkgver}
40 PYTHON=/usr/bin/python2 ./configure \
43 --libexecdir=/usr/bin \
45 --enable-gimp-console \
47 --disable-check-update \
49 --with-bug-report-url='https://bugs.archlinux.org/?string=gimp' \
52 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
57 cd ${pkgname}-${pkgver}
58 make DESTDIR="${pkgdir}" install
59 install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
61 rm "${pkgdir}/usr/share/man/man1/gimp-console.1"
62 ln -s gimp-console-${pkgver%.*}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
63 ln -s gimptool-2.0 "${pkgdir}/usr/bin/gimptool"
64 ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"