OCaml 4.13.1 rebuild
[arch-packages.git] / nghttp2 / repos / testing-x86_64 / PKGBUILD
blob87bd7d7ef18ac335a3c3e31365c47633716e360a
1 # Maintainer: Anatol Pomozov
2 # Contributor: Zhuoyun Wei <wzyboy@wzyboy.org>
4 pkgname=nghttp2
5 pkgver=1.46.0
6 pkgrel=2
7 pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library'
8 arch=(x86_64)
9 url='https://nghttp2.org/'
10 license=(MIT)
11 depends=(openssl libev zlib libxml2 jansson jemalloc c-ares libnghttp2 systemd-libs)
12 makedepends=(systemd cython python-setuptools)
13 options=(!emptydirs)
14 source=(https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz)
15 backup=(
16   etc/nghttpx/nghttpx.conf
17   etc/logrotate.d/nghttpx
19 sha512sums=('fcf3573bcc421705190c7cf0e3230f6f3028b669cb2976d29cfeb73e706deaae91ce60d0a615472e3f296454049ea5798f1e8defdd260a98895e94fea6a7a16b')
21 build() {
22   cd nghttp2-$pkgver
24   autoreconf -i
25   ./configure \
26     --prefix=/usr \
27     --disable-examples
28   make
31 check() {
32   cd nghttp2-$pkgver
33   make check
36 package() {
37   cd nghttp2-$pkgver
39   make DESTDIR="$pkgdir" install
40   make -C lib DESTDIR="$pkgdir" uninstall
42   install -Dm644 contrib/nghttpx.service "$pkgdir/usr/lib/systemd/system/nghttpx.service"
43   install -Dm644 contrib/nghttpx-logrotate "$pkgdir/etc/logrotate.d/nghttpx"
44   install -Dm644 nghttpx.conf.sample "$pkgdir/etc/nghttpx/nghttpx.conf"
45   install -Dm644 COPYING "$pkgdir/usr/share/licenses/nghttp2/COPYING"