OCaml 4.13.1 rebuild
[arch-packages.git] / shadow / repos / core-x86_64 / PKGBUILD
blobde451df3f5b133642f8fc336a8e3f5a1f6ec53b4
1 # Maintainer: Dave Reisner <dreisner@archlinux.org>
2 # Maintainer: Aaron Griffin <aaron@archlinux.org>
4 pkgname=shadow
5 pkgver=4.8.1
6 pkgrel=4
7 pkgdesc="Password and account management tool suite with support for shadow files and PAM"
8 arch=('x86_64')
9 url='https://github.com/shadow-maint/shadow'
10 license=('BSD')
11 # libcap-ng needed by install scriptlet for 'filecap'
12 depends=('pam' 'acl' 'libacl.so' 'audit' 'libaudit.so' 'libcap-ng' 'libcap-ng.so'
13          'libxcrypt' 'libcrypt.so')
14 backup=(etc/login.defs
15         etc/pam.d/{chage,passwd,shadow,useradd,usermod,userdel}
16         etc/pam.d/{chpasswd,newusers,groupadd,groupdel,groupmod}
17         etc/pam.d/{chgpasswd,groupmems}
18         etc/default/useradd)
19 options=(strip debug)
20 validpgpkeys=('D5C2F9BFCA128BBA22A77218872F702C4D6E25A8'   # Christian Perrier
21               'F1D08DB778185BF784002DFFE9FEEA06A85E3F9D')  # Serge Hallyn
22 source=("https://github.com/shadow-maint/shadow/releases/download/$pkgver/shadow-$pkgver.tar.xz"{,.asc}
23         LICENSE
24         chgpasswd
25         chpasswd
26         defaults.pam
27         login.defs
28         newusers
29         passwd
30         shadow.{timer,service}
31         useradd.defaults)
32 install=shadow.install
33 sha1sums=('63457a0ba58dc4e81b2663b839dc6c89d3343f12'
34           'SKIP'
35           '33a6cf1e44a1410e5c9726c89e5de68b78f5f922'
36           '4ad0e059406a305c8640ed30d93c2a1f62c2f4ad'
37           '12427b1ca92a9b85ca8202239f0d9f50198b818f'
38           '0e56fed7fc93572c6bf0d8f3b099166558bb46f1'
39           '81a02eadb5f605fef5c75b6d8a03713a7041864b'
40           '12427b1ca92a9b85ca8202239f0d9f50198b818f'
41           '611be25d91c3f8f307c7fe2485d5f781e5dee75f'
42           'a154a94b47a3d0c6c287253b98c0d10b861226d0'
43           'b5540736f5acbc23b568973eb5645604762db3dd'
44           'c173208c5cf34528602f9931468a67b7f68abad3')
46 build() {
47   cd "$pkgname-$pkgver"
49   autoreconf -fsiv
50   ./configure \
51     --prefix=/usr \
52     --bindir=/usr/bin \
53     --sbindir=/usr/bin \
54     --libdir=/usr/lib \
55     --mandir=/usr/share/man \
56     --sysconfdir=/etc \
57     --disable-account-tools-setuid \
58     --with-libpam \
59     --with-group-name-max-length=32 \
60     --with-audit \
61     --without-selinux
63   make
66 package() {
67   cd "$pkgname-$pkgver"
69   make DESTDIR="$pkgdir" install
71   # license
72   install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/shadow/LICENSE"
74   # useradd defaults
75   install -Dm600 "$srcdir/useradd.defaults" "$pkgdir/etc/default/useradd"
77   # systemd units
78   install -D -m644 "$srcdir/shadow.timer" "$pkgdir/usr/lib/systemd/system/shadow.timer"
79   install -D -m644 "$srcdir/shadow.service" "$pkgdir/usr/lib/systemd/system/shadow.service"
80   install -d -m755 "$pkgdir/usr/lib/systemd/system/timers.target.wants"
81   ln -s ../shadow.timer "$pkgdir/usr/lib/systemd/system/timers.target.wants/shadow.timer"
83   # login.defs
84   install -Dm644 "$srcdir/login.defs" "$pkgdir/etc/login.defs"
86   # PAM config - custom
87   rm "$pkgdir/etc/pam.d"/*
88   install -t "$pkgdir/etc/pam.d" -m644 "$srcdir"/{passwd,chgpasswd,chpasswd,newusers}
90   # PAM config - from tarball
91   install -Dm644 etc/pam.d/groupmems "$pkgdir/etc/pam.d/groupmems"
93   # we use the 'useradd' PAM file for other similar utilities
94   for file in chage groupadd groupdel groupmod shadow \
95       useradd usermod userdel; do
96     install -Dm644 "$srcdir/defaults.pam" "$pkgdir/etc/pam.d/$file"
97   done
99   # Remove evil/broken tools
100   rm "$pkgdir"/usr/sbin/logoutd
102   # Remove utilities provided by util-linux
103   rm \
104       "$pkgdir"/usr/bin/{login,su,chsh,chfn,sg,nologin} \
105       "$pkgdir"/usr/sbin/{vipw,vigr}
107   # but we keep newgrp, as sg is really an alias to it
108   mv "$pkgdir"/usr/bin/{newgrp,sg}
110   # ...and their many man pages
111   find "$pkgdir"/usr/share/man \
112       '(' -name 'chsh.1'    -o \
113           -name 'chfn.1'    -o \
114           -name 'su.1'      -o \
115           -name 'logoutd.8' -o \
116           -name 'login.1'   -o \
117           -name 'nologin.8' -o \
118           -name 'vipw.8'    -o \
119           -name 'vigr.8'    -o \
120           -name 'newgrp.1' ')' \
121       -delete
122   rmdir \
123       "$pkgdir"/usr/share/man/{fi,id,zh_TW}/man1 \
124       "$pkgdir"/usr/share/man/{fi,ko/man8}
126   # move everything else to /usr/bin, because this isn't handled by ./configure
127   mv "$pkgdir"/usr/sbin/* "$pkgdir"/usr/bin
128   rmdir "$pkgdir/usr/sbin"