sbcl rebuild
[arch-packages.git] / gimp / trunk / PKGBUILD
blobf6e438cea0490ed2f759f7b12e4df0913d18b72c
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Daniel Isenmann <daniel@archlinux.org>
4 pkgname=gimp
5 pkgver=2.10.32
6 pkgrel=1
7 pkgdesc='GNU Image Manipulation Program'
8 url='https://www.gimp.org/'
9 arch=('x86_64')
10 license=('GPL' 'LGPL')
11 depends=('babl' 'dbus-glib' 'desktop-file-utils' 'gegl' 'glib-networking' 'hicolor-icon-theme'
12          'openjpeg2' 'lcms2' 'libheif' 'libexif' 'libgudev' 'libmng' 'libmypaint' 'librsvg' 'libwebp'
13          'libwmf' 'libxmu' 'libxpm' 'mypaint-brushes1' 'openexr' 'poppler-data' 'gtk2' 'graphviz')
14 makedepends=('alsa-lib' 'curl' 'ghostscript' 'gtk-doc' 'intltool' 'iso-codes' 'poppler-glib')
15 optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
16             'poppler-glib: for pdf support'
17             'alsa-lib: for MIDI event controller module'
18             'curl: for URI support'
19             'ghostscript: for postscript support'
20             'gvfs: for HTTP/S support (and many other schemes)')
21 conflicts=('gimp-plugin-wavelet-decompose')
22 replaces=('gimp-plugin-wavelet-decompose')
23 options=('debug')
24 install=gimp.install
25 source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
26         0001-no-check-update.patch
27         linux.gpl)
28 sha256sums=('3f15c70554af5dcc1b46e6dc68f3d8f0a6cc9fe56b6d78ac08c0fd859ab89a25'
29             'ac3e8b44cf391f4ab3050652f2cc1f146f451fb25178d5a596d905f5bad13fcf'
30             '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
32 prepare() {
33   cd ${pkgname}-${pkgver}
35   patch -Np1 < ../0001-no-check-update.patch
36   autoreconf -vi
39 build() {
40 pkg-config --exists --print-errors "OpenEXR >= 1.6.1"
41   cd ${pkgname}-${pkgver}
42   PYTHON=/usr/bin/python2 ./configure \
43     --prefix=/usr \
44     --sysconfdir=/etc \
45     --libexecdir=/usr/bin \
46     --enable-mp \
47     --enable-gimp-console \
48     --enable-gtk-doc \
49     --disable-check-update \
50     --disable-python \
51     --with-bug-report-url='https://bugs.archlinux.org/?string=gimp' \
52     --with-openexr \
53     --without-aa
54   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
55   make
58 package() {
59   cd ${pkgname}-${pkgver}
60   make DESTDIR="${pkgdir}" install
61   install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
63   rm "${pkgdir}/usr/share/man/man1/gimp-console.1"
64   ln -s gimp-console-${pkgver%.*}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
65   ln -s gimptool-2.0 "${pkgdir}/usr/bin/gimptool"
66   ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"
69 # vim: ts=2 sw=2 et: