sbcl rebuild
[arch-packages.git] / gnome-weather / trunk / PKGBUILD
blob76de587940f5cada4319f04775440b6370f53678
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-weather
4 pkgver=42.0
5 pkgrel=1
6 pkgdesc="Access current weather conditions and forecasts"
7 url="https://wiki.gnome.org/Apps/Weather"
8 arch=(any)
9 license=(GPL)
10 depends=(gtk4 gjs libgweather-4 geoclue libadwaita)
11 makedepends=(gobject-introspection appstream-glib git meson)
12 groups=(gnome)
13 _commit=9165610014d95c5a93e61d8d11d91dc98d1adc33  # tags/42.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-weather.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"