sbcl rebuild
[arch-packages.git] / hyphen-de / repos / extra-any / PKGBUILD
blob2d749eb4f9b24618b0bf7b4c366323203ba626b3
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=hyphen-de
4 pkgver=20060120
5 pkgrel=6
6 pkgdesc="German hyphenation rules"
7 arch=(any)
8 url="https://www.openoffice.org/lingucomponent/"
9 license=('LGPL')
10 optdepends=('hyphen: offers hyphenation library functions')
11 source=(#http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/hyph_de_DE.zip
12         #http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/hyph_de_CH.zip
13         # mirror from ApacheOpenOffice - see: http://www.openoffice.org/distribution/mirrors/master.html
14         # http://sunsite.informatik.rwth-aachen.de/ftp/pub/mirror/OpenOffice/contrib/dictionaries/hyph_de_DE.zip
15         # http://sunsite.informatik.rwth-aachen.de/ftp/pub/mirror/OpenOffice/contrib/dictionaries/hyph_de_CH.zip
16         https://www.mirrorservice.org/sites/download.openoffice.org/contrib/dictionaries/hyph_de_DE.zip
17         https://www.mirrorservice.org/sites/download.openoffice.org/contrib/dictionaries/hyph_de_CH.zip)
18 md5sums=('20e5b706ee3201aa2741dabca824cd8b'
19          '7b8567cc0ee1623dded40f2cba366e91')
21 build() {
22   /bin/true
25 package() {
26   cd "$srcdir"
27   install -dm755 "${pkgdir}"/usr/share/hyphen
28   cp -p hyph_de_??.* "$pkgdir"/usr/share/hyphen
30   pushd "$pkgdir"/usr/share/hyphen/
31   de_DE_aliases="de_AT de_BE de_LU"
32   for lang in $de_DE_aliases; do
33         ln -s hyph_de_DE.dic hyph_$lang.dic
34   done
35   de_CH_aliases="de_LI"
36   for lang in $de_CH_aliases; do
37         ln -s hyph_de_CH.dic hyph_$lang.dic
38   done
40   popd
42   # the symlinks
43   install -dm755 "${pkgdir}"/usr/share/myspell/dicts
44   pushd "$pkgdir"/usr/share/myspell/dicts
45     for file in "$pkgdir"/usr/share/hyphen/*; do
46       ln -sv /usr/share/hyphen/$(basename $file) .
47     done
48   popd
49   
50   # docs
51   install -dm755 "${pkgdir}"/usr/share/doc/$pkgname
52   cp -p README_hyph_de_DE.txt "$pkgdir"/usr/share/doc/$pkgname
53   cp -p README_hyph_de_CH.txt "$pkgdir"/usr/share/doc/$pkgname