sbcl rebuild
[arch-packages.git] / libnghttp2 / trunk / PKGBUILD
blob0163f8c7441c7af5a88a0bc1f9e500568ec584ec
1 # Maintainer: Anatol Pomozov
2 # Contributor: Zhuoyun Wei <wzyboy@wzyboy.org>
4 pkgname=libnghttp2
5 pkgver=1.49.0
6 pkgrel=1
7 pkgdesc='Framing layer of HTTP/2 is implemented as a reusable C library'
8 arch=(x86_64)
9 url='https://nghttp2.org/'
10 license=(MIT)
11 depends=(glibc)
12 conflicts=('nghttp2<1.20.0-2')
13 source=(https://github.com/nghttp2/nghttp2/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz)
14 sha512sums=('599bc8e52bbe7f5bdfbf493ea2199c4c4bdeb9eac174d4c56b11fb321b11b86e82674bd3c7f60d7ea975ef60eec3f258b5438d1157491cfa23a1b9adccd7948a')
16 build() {
17   cd nghttp2-$pkgver
19   autoreconf -i
20   ./configure \
21     --prefix=/usr \
22     --disable-examples \
23     --disable-python-bindings \
24     --enable-lib-only
25   make
28 check() {
29   cd nghttp2-$pkgver
30   make check
33 package() {
34   cd nghttp2-$pkgver/lib
36   make DESTDIR="$pkgdir" install
37   install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/libnghttp2/COPYING"