sbcl rebuild
[arch-packages.git] / lprint / trunk / PKGBUILD
blob279ca36738b4445a2f8427f88b7704d28a7ef0ec
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: WorMzy Tykashi <wormzy.tykashi@gmail.com>
4 pkgname=lprint
5 pkgver=1.1.0
6 pkgrel=2
7 pkgdesc="Label Printer Application"
8 arch=('x86_64')
9 url="https://www.msweet.org/lprint/"
10 license=('Apache' 'custom')
11 depends=('pappl' 'libcups' 'libpng' 'libusb' 'pam')
12 options=('debug')
13 source=("https://github.com/michaelrsweet/lprint/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.sig}
14         fix-systemd-installdir.patch)
15 #validpgpkeys=('845464660B686AAB36540B6F999559A027815955')  # "Michael R Sweet <michael.r.sweet@gmail.com>"
16 validpgpkeys=('9086C3CDC66C3F563CF8F405BE67C75EC81F3244') # "Michael R Sweet <msweet@msweet.org>"
17 sha256sums=('d40e353ac9f6b0de96974717255fa1df0f9655d37ef3f9a6f35b6391992daf73'
18             'SKIP'
19             '5afaf8dad1e766f0c99a27095e56face16d2eae681d576c395db5d3c3761d182')
21 prepare() {
22   cd ${pkgname}-${pkgver}
23   patch -Np1 -i ../fix-systemd-installdir.patch
26 build() {
27   cd ${pkgname}-${pkgver}
28   ./configure --prefix=/usr
29   make
32 check() {
33    cd "$pkgname-$pkgver"
34    #make -k check
37 package() {
38   cd ${pkgname}-${pkgver}
39   make DESTDIR="${pkgdir}" install
40   # add license + exception
41   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}
43   # workaround until next release - FS#75465 / https://github.com/michaelrsweet/lprint/pull/63
44   sed -i "s:/local::" "${pkgdir}"/usr/lib/systemd/system/lprint.service